summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 061f6a0..0977d89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,7 +134,9 @@ PKG_CHECK_MODULES(LCMS, lcms2 >= 2.2)
dnl ---------------------------------------------------------------------------
dnl - Build VALA support
dnl ---------------------------------------------------------------------------
-if test x$found_introspection != xno; then
+AC_ARG_ENABLE(vala, AS_HELP_STRING([--enable-vala],[build vala bindings]),
+ enable_vala=$enableval,enable_vala=no)
+if test x$found_introspection != xno -a x$enable_vala != xno; then
AC_PATH_PROG([VAPIGEN], [vapigen], [])
if test "x$VAPIGEN" = "x"; then
has_vapigen="no"
@@ -144,7 +146,9 @@ if test x$found_introspection != xno; then
fi
else
has_vapigen="no"
- AC_MSG_WARN([Not introspection found, will not build Vala binding])
+ if test x$found_introspection = xno; then
+ AC_MSG_WARN([introspection not found, will not build Vala binding])
+ fi
fi
AM_CONDITIONAL(HAVE_VAPIGEN, [test "x$has_vapigen" = "xyes"])