summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7821b1..5583076 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,6 +248,10 @@ AM_CONDITIONAL(CD_BUILD_POLKIT, test x$enable_polkit = xyes)
if test x$enable_polkit = xyes; then
PKG_CHECK_MODULES(POLKIT, polkit-gobject-1 >= 0.103)
AC_DEFINE(USE_POLKIT, 1, [if we should use PolicyKit])
+
+ PKG_CHECK_EXISTS([polkit-gobject-1 >= 0.114],
+ [AC_DEFINE(POLKIT_HAS_AUTOPTR_MACROS, 1, [if PolKit has autoptr macros])],
+ [])
fi
dnl ---------------------------------------------------------------------------