summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build50
1 files changed, 29 insertions, 21 deletions
diff --git a/man/meson.build b/man/meson.build
index 54d83e5..b9e3b9e 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -1,41 +1,49 @@
-docbook2man = find_program('docbook2man')
+xsltproc = find_program('xsltproc')
+
+stylesheet_url = 'http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl'
+ret = run_command(xsltproc, '--nonet', stylesheet_url)
+if ret.returncode() != 0
+ error('Cannot build man pages without docbook-xsl-ns')
+endif
+
+xsltproc_args = [
+ xsltproc,
+ '--output', '@OUTPUT@',
+ '--nonet',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'funcsynopsis.style', 'ansi',
+ stylesheet_url,
+ '@INPUT@',
+]
+
custom_target('colormgr-man',
input : 'colormgr.xml',
- output : 'colormgr.1',
- command : [
- docbook2man, '@INPUT@',
- '--output', meson.current_build_dir(),
- ],
+ output : '@BASENAME@.1',
+ command : xsltproc_args,
install : true,
install_dir : join_paths(mandir, 'man1'),
)
custom_target('cd-create-profile-man',
input : 'cd-create-profile.xml',
- output : 'cd-create-profile.1',
- command : [
- docbook2man, '@INPUT@',
- '--output', meson.current_build_dir(),
- ],
+ output : '@BASENAME@.1',
+ command : xsltproc_args,
install : true,
install_dir : join_paths(mandir, 'man1'),
)
custom_target('cd-fix-profile-man',
input : 'cd-fix-profile.xml',
- output : 'cd-fix-profile.1',
- command : [
- docbook2man, '@INPUT@',
- '--output', meson.current_build_dir(),
- ],
+ output : '@BASENAME@.1',
+ command : xsltproc_args,
install : true,
install_dir : join_paths(mandir, 'man1'),
)
custom_target('cd-it8-man',
input : 'cd-it8.xml',
- output : 'cd-it8.1',
- command : [
- docbook2man, '@INPUT@',
- '--output', meson.current_build_dir(),
- ],
+ output : '@BASENAME@.1',
+ command : xsltproc_args,
install : true,
install_dir : join_paths(mandir, 'man1'),
)