summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2015-09-08 23:13:47 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2015-09-08 23:13:47 +0000
commitcdb8032c23e36ac8a182b5f9aea097a1940ed083 (patch)
tree1d5bc60311b4c14fdb639242b353f0a066a6b6a7 /CMakeLists.txt
parentd566c4556b2c8c59c01da5b8be013a5675332bf3 (diff)
downloadcompiler-rt-cdb8032c23e36ac8a182b5f9aea097a1940ed083.tar.gz
[CMake] Remove all uses of LLVM_NATIVE_ARCH.
Instead, assume we're going to target triple specified by COMPILER_RT_DEFAULT_TARGET_TRIPLE and build runtimes for this triple (and hope that the host compiler can target them). This will help users that use cross-compiler on their host to build Clang that would work on a different architecture. This will also come in handy if one would want to configure several compiler-rt build trees on the same host, using just-built Clang that can target many architectures. This doesn't change the behavior in the default build configuration. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@247099 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 669abba07..84413ad1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,8 +255,7 @@ endif()
# FIXME: Fix all sanitizers and add -Wframe-larger-than to
# SANITIZER_COMMON_FLAGS
if(COMPILER_RT_HAS_WFRAME_LARGER_THAN_FLAG AND NOT COMPILER_RT_DEBUG
- AND NOT ${LLVM_NATIVE_ARCH} STREQUAL "PowerPC"
- AND NOT ${LLVM_NATIVE_ARCH} STREQUAL "Mips")
+ AND NOT ${COMPILER_RT_DEFAULT_TARGET_ARCH} MATCHES "powerpc|mips")
set(SANITIZER_LIMIT_FRAME_SIZE TRUE)
else()
set(SANITIZER_LIMIT_FRAME_SIZE FALSE)