summaryrefslogtreecommitdiff
path: root/lib/lsan/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Matveev <earthdok@google.com>2013-11-25 17:39:36 +0000
committerSergey Matveev <earthdok@google.com>2013-11-25 17:39:36 +0000
commit74c88796a4024922144660ed1ade519af5008fe2 (patch)
tree47b21dbbf4aa654445a607b5315a7568a671bb78 /lib/lsan/CMakeLists.txt
parent12f610efe6f48efb2d03b985b3b2a36d4556fca7 (diff)
downloadcompiler-rt-74c88796a4024922144660ed1ade519af5008fe2.tar.gz
Merging r195642:
------------------------------------------------------------------------ r195642 | smatveev | 2013-11-25 18:25:36 +0400 (Mon, 25 Nov 2013) | 5 lines [lsan] Unbreak standalone LSan's initialization by making it more like ASan's. No longer allow interceptors to be called during initialization, use the preinit array (instead of initializing at the first call to an intercepted function) and adopt the calloc() hack from ASan. ------------------------------------------------------------------------ git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/branches/release_34@195666 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/lsan/CMakeLists.txt')
-rw-r--r--lib/lsan/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/lsan/CMakeLists.txt b/lib/lsan/CMakeLists.txt
index b2e88bcaf..3018a0662 100644
--- a/lib/lsan/CMakeLists.txt
+++ b/lib/lsan/CMakeLists.txt
@@ -9,10 +9,11 @@ set(LSAN_COMMON_SOURCES
lsan_common_linux.cc)
set(LSAN_SOURCES
- lsan_interceptors.cc
+ lsan.cc
lsan_allocator.cc
- lsan_thread.cc
- lsan.cc)
+ lsan_interceptors.cc
+ lsan_preinit.cc
+ lsan_thread.cc)
set(LSAN_SRC_DIR ${CMAKE_CURRENT_SOURCE_DIR})