summaryrefslogtreecommitdiff
path: root/test/cfi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/cfi/CMakeLists.txt')
-rw-r--r--test/cfi/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/cfi/CMakeLists.txt b/test/cfi/CMakeLists.txt
index a6f136512..21463ac40 100644
--- a/test/cfi/CMakeLists.txt
+++ b/test/cfi/CMakeLists.txt
@@ -21,6 +21,11 @@ if(NOT COMPILER_RT_STANDALONE_BUILD)
LTO
)
endif()
+ if(WIN32 AND EXISTS ${CMAKE_SOURCE_DIR}/tools/lld)
+ list(APPEND CFI_TEST_DEPS
+ lld
+ )
+ endif()
endif()
add_lit_testsuite(check-cfi "Running the cfi regression tests"