summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Short <keithshort@chromium.org>2022-10-28 11:38:13 -0600
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-11-04 19:09:57 +0000
commitbfb09dd789ef4eedcc213abe0aacb2646874626b (patch)
tree956647b7cdce0e14c4601cf7fa6a37a080925d97 /CMakeLists.txt
parent366174d656fbc6d853f8d31e0751c35bff5aeaaf (diff)
downloadchrome-ec-bfb09dd789ef4eedcc213abe0aacb2646874626b.tar.gz
zephyr: Create CMake variable for the program directory
Many board tests need a path to the board specific sources. Add PROGRAM_EC_PROGRAM_DIR as a helper variable BUG=b:254097139 BRANCH=none TEST=twister -v -i -c Signed-off-by: Keith Short <keithshort@chromium.org> Change-Id: I71a7c555101fff3ba6158962cd333da642562b24 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/4000782 Reviewed-by: Jeremy Bettis <jbettis@chromium.org> Code-Coverage: Zoss <zoss-cl-coverage@prod.google.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b2f3525fe..e4d48e00b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,9 @@ endif()
set(PLATFORM_EC "${ZEPHYR_CURRENT_MODULE_DIR}" CACHE PATH
"Path to the platform/ec repo.")
+set(PLATFORM_EC_PROGRAM_DIR "${PLATFORM_EC}/zephyr/projects" CACHE PATH
+ "Path to the root directory containing all Zephyr EC programs and projects.")
+
if(NOT EXISTS "${PLATFORM_EC}/zephyr/module.yml")
message(FATAL_ERROR "Failed to resolve PLATFORM_EC at
${PLATFORM_EC}/zephyr/module.yml")