summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBrian J. Nemec <bnemec@chromium.org>2020-04-06 22:46:48 -0700
committerCommit Bot <commit-bot@chromium.org>2020-04-08 23:45:00 +0000
commit752edaacb1867a74e548308217f843ea7a2962eb (patch)
tree3b797609b3a77d90d11bd542ad7ddba3f7435e47 /setup.py
parent3c11c513542f692e26b15277799ccc90d0c6455d (diff)
downloadchrome-ec-752edaacb1867a74e548308217f843ea7a2962eb.tar.gz
servo_updater: Add Servo V4.1 to flash and servo updater
Adds the Servo V4.1 to the servo updater as the target 'servo_v41'. Some minor cleanup was done on the servo_updater logic to make it clearer which issue is occurring and to address common substrings in 'servo_v4' and 'servo_v41' by extracting the binary name from the config files directly rather than inferring from the name. BUG=b:153391164 TEST=sudo emerge chromeos-base/ec-devutils TEST=flash_ec --board=servo_v41 --image ec.bin Verify the flash_ec using the STM32 DFU to flash the image on reworked board with compatible BC1.2 change TEST=sudo servo_updater -b servo_v41 Verify the servo_updater finds the latest servo_v4.1 version and flashes it TEST=Attempted to flash V4 and V41 devices with each other's images verified that the checks prevent flashing the other version. Change-Id: I77d94ce9a641f39b7ee446af05e52441b7762c96 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2138638 Tested-by: Brian Nemec <bnemec@chromium.org> Reviewed-by: Ruben Rodriguez Buchillon <coconutruben@chromium.org> Commit-Queue: Brian Nemec <bnemec@chromium.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index cb75210b22..df1b6fb4e7 100644
--- a/setup.py
+++ b/setup.py
@@ -41,6 +41,7 @@ setup(
data_files=[("share/servo_updater/configs",
["extra/usb_updater/c2d2.json",
"extra/usb_updater/servo_v4.json",
+ "extra/usb_updater/servo_v41.json",
"extra/usb_updater/servo_micro.json",
"extra/usb_updater/sweetberry.json"])],
description="Servo usb updater.",