summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Yilun Lin <yllin@chromium.org>2021-11-30 16:51:40 +0800
committerCommit Bot <commit-bot@chromium.org>2021-12-02 04:35:12 +0000
commit8e1ac80d98f2349a133e717e44f50948687706f6 (patch)
tree4a5c4ddaf83cd2f2ad2ab10b1a8a536ac1cbfd19 /zephyr/CMakeLists.txt
parent84fdf0ddddbd78eabe2fad28627ab0206e403248 (diff)
downloadchrome-ec-8e1ac80d98f2349a133e717e44f50948687706f6.tar.gz
zephyr: kconfig: add RT1718S PPC/TCPC config
Add PLATFORM_EC_USBC_PPC_RT1718S, and PLATFORM_EC_USB_PD_TCPM_RT1718S. BUG=b:203739613 TEST=zmake testall BRANCH=none Change-Id: I663bbb29f38dfc925675a6f1beddeb3c976722fe Signed-off-by: Eric Yilun Lin <yllin@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3310017 Commit-Queue: Eric Yilun Lin <yllin@google.com> Tested-by: Eric Yilun Lin <yllin@google.com> Reviewed-by: Abe Levkoy <alevkoy@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index b8d1744c23..dab7882231 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -408,6 +408,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8815
"${PLATFORM_EC}/driver/tcpm/ps8xxx.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_RT1715
"${PLATFORM_EC}/driver/tcpm/rt1715.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_RT1718S
+ "${PLATFORM_EC}/driver/tcpm/rt1718s.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_TUSB422
"${PLATFORM_EC}/driver/tcpm/tusb422.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_TCPCI
@@ -429,6 +431,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_PPC_SN5S330
"${PLATFORM_EC}/driver/ppc/sn5s330.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_PPC_SYV682X
"${PLATFORM_EC}/driver/ppc/syv682x.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_PPC_RT1718S
+ "${PLATFORM_EC}/driver/ppc/rt1718s.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_VBOOT_HASH
"${PLATFORM_EC}/common/vboot_hash.c")