summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorDiana Z <dzigterman@chromium.org>2021-10-21 15:22:19 -0600
committerCommit Bot <commit-bot@chromium.org>2021-10-25 18:36:08 +0000
commit95c9d0eab0a2997bef9711fbffaf6a50a76aa093 (patch)
tree26402f839633cb3521e228e09770d7043e166c16 /zephyr/CMakeLists.txt
parent7bb14efa8e1ceec17771f6333c286e6899ac54e3 (diff)
downloadchrome-ec-95c9d0eab0a2997bef9711fbffaf6a50a76aa093.tar.gz
Zephyr: Add NCT380XX config
Add config for the NCT38XX chip. BRANCH=None BUG=b:195137794 TEST=zmake testall Signed-off-by: Diana Z <dzigterman@chromium.org> Change-Id: Ice2967c021f38e51d3981ac0e74ba9a04a8ed986 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3238142 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 703b42cd3d..e864c2d3b8 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -369,6 +369,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_DRP_ACC_TRYSRC
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PRL_SM
"${PLATFORM_EC}/common/usbc/usb_prl_sm.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_NCT38XX
+ "${PLATFORM_EC}/driver/tcpm/nct38xx.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8751
"${PLATFORM_EC}/driver/tcpm/ps8xxx.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8805