summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Yilun Lin <yllin@chromium.org>2021-11-29 11:09:37 +0800
committerCommit Bot <commit-bot@chromium.org>2021-11-29 10:48:21 +0000
commitaf42062a920fb032711604b79c731aecf851d55e (patch)
treea750b3d2991d000264c119eb4bdd2b50c32b22d4 /zephyr/CMakeLists.txt
parentdc2616addb35c36d6041e9b8885b3512272b1505 (diff)
downloadchrome-ec-af42062a920fb032711604b79c731aecf851d55e.tar.gz
zephyr: kconfig: add PLATOFRM_EC_MATH_UTIL
Make this config independent since it has been dependent to many configs includes motion sensors and USB-PD. BUG=none TEST=zmake testall; grep math_util.o and no config directly uses it. BRANCH=none Change-Id: Id755a28e3f3da99a32b22c0d2e0b1228e7d7e6d0 Signed-off-by: Eric Yilun Lin <yllin@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3305648 Tested-by: Eric Yilun Lin <yllin@google.com> Auto-Submit: Eric Yilun Lin <yllin@google.com> Reviewed-by: Fabio Baltieri <fabiobaltieri@google.com> Commit-Queue: Fabio Baltieri <fabiobaltieri@google.com>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 1a7c84fd09..b8d1744c23 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -121,15 +121,13 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC "${PLATFORM_EC}/common/base32.c"
zephyr_library_sources_ifdef(CONFIG_HAS_TASK_POWERBTN
"${PLATFORM_EC}/common/power_button_x86.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_ACCEL_BMA255
- "${PLATFORM_EC}/driver/accel_bma2x2.c"
- "${PLATFORM_EC}/common/math_util.c")
+ "${PLATFORM_EC}/driver/accel_bma2x2.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_ACCEL_KX022
"${PLATFORM_EC}/driver/accel_kionix.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_ACCEL_LIS2DW12
"${PLATFORM_EC}/driver/accel_lis2dw12.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_ACCELGYRO_BMI
- "${PLATFORM_EC}/driver/accelgyro_bmi_common.c"
- "${PLATFORM_EC}/common/math_util.c")
+ "${PLATFORM_EC}/driver/accelgyro_bmi_common.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_ACCELGYRO_BMI160
"${PLATFORM_EC}/driver/accelgyro_bmi160.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_ACCELGYRO_BMI260
@@ -260,8 +258,7 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_PWM
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_ONOFF_STATES
"${PLATFORM_EC}/common/led_onoff_states.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LID_ANGLE
- "${PLATFORM_EC}/common/motion_lid.c"
- "${PLATFORM_EC}/common/math_util.c")
+ "${PLATFORM_EC}/common/motion_lid.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LID_ANGLE_UPDATE
"${PLATFORM_EC}/common/lid_angle.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LID_SWITCH
@@ -445,3 +442,5 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_VSTORE
"${PLATFORM_EC}/common/vstore.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_RTC
"${PLATFORM_EC}/common/rtc.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_MATH_UTIL
+ "${PLATFORM_EC}/common/math_util.c")