summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorYuval Peress <peress@chromium.org>2021-09-01 20:55:45 -0600
committerCommit Bot <commit-bot@chromium.org>2021-09-03 19:52:46 +0000
commit0c0ba0a2b1297fa9bb1c47da95c220ae1df3b9e2 (patch)
tree6870edf030f696d8a61053c4cc1aee6ff263b51d /zephyr/CMakeLists.txt
parenta42b82561483d046b08bb177b02393104ce88c0b (diff)
downloadchrome-ec-0c0ba0a2b1297fa9bb1c47da95c220ae1df3b9e2.tar.gz
test: accel_cal: fix for gitlab
Fix a rounding error. See documentation for details. It is important to include the detailed documentation as it provides strong details for why these flags are necessary. It will avoid confusion in the future. BRANCH=none BUG=b:178731498 TEST=zmake configure --test zephyr/test/accel_cal (both in chroot and in gitlab docker). Change-Id: Ie040f49dfaacb84dc10b76481a16213be6a2f09e Signed-off-by: Yuval Peress <peress@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3139254 Reviewed-by: Jeremy Bettis <jbettis@chromium.org> Reviewed-by: Paul Fagerburg <pfagerburg@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 25f1962319..e44befc1f1 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -42,6 +42,8 @@ if(DEFINED CONFIG_PLATFORM_EC)
# Force compiler warnings to generate errors
zephyr_compile_options(-Werror)
+ include(fpu.cmake)
+
# When LTO is enabled, enable only for the "app" library, which compiles
# and links all Chromium OS sources.
# TODO: Enable LTO for all sources when Zephyr supports it.