summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorBoris Mittelberg <bmbm@google.com>2021-03-30 19:41:07 +0000
committerCommit Bot <commit-bot@chromium.org>2021-05-10 22:34:45 +0000
commit3a2f77758104a581ade2ecb406b8d099eada6a90 (patch)
treee1e958329a24189d8ee5fe0120632e4b03682a94 /zephyr/CMakeLists.txt
parentddf11157cd952a6df79aefc06c456eea426b6f10 (diff)
downloadchrome-ec-3a2f77758104a581ade2ecb406b8d099eada6a90.tar.gz
mkbp: EC buttons and switches via MKBP
Allowing EC buttons and switches to be signaled via MKBP protocol, using CONFIG_MKBP_INPUT_DEVICES. Default behaviour is unchanged. BUG=b:170966461 BRANCH=main,firmware-dedede-13606.B,firmware-volteer-13672.B-main TEST=None Signed-off-by: Boris Mittelberg <bmbm@google.com> Cq-Depend: chromium:2824044 Change-Id: Ib96f98ecb3717a8ee8963be69fb7d7eb72e6d132 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2796382
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index acec9dfb46..0153ff7900 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -291,6 +291,10 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_KEYBOARD_PROTOCOL_MKBP
"${PLATFORM_EC}/common/keyboard_mkbp.c"
"${PLATFORM_EC}/common/mkbp_fifo.c"
"${PLATFORM_EC}/common/mkbp_info.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_MKBP_INPUT_DEVICES
+ "${PLATFORM_EC}/common/mkbp_input_devices.c"
+ "${PLATFORM_EC}/common/mkbp_fifo.c"
+ "${PLATFORM_EC}/common/mkbp_info.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_KEYBOARD_VIVALDI
"${PLATFORM_EC}/common/keyboard_vivaldi.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_PWM_KBLIGHT