summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Glass <sjg@chromium.org>2021-06-04 16:10:08 -0600
committerCommit Bot <commit-bot@chromium.org>2021-06-15 18:38:30 +0000
commit81e819908e1da88b0cb432f594e353e92f0b886c (patch)
tree86149928bc0a87a413098069a2730a33aff14bb9 /zephyr/CMakeLists.txt
parentf6f0ec7de7056ff6e0d72b5af7709bbfc42ec226 (diff)
downloadchrome-ec-81e819908e1da88b0cb432f594e353e92f0b886c.tar.gz
zephyr: Add support for the PS8743 USB mux
Add a Kconfig for this chip so it can be used with zephyr. BUG=b:189855648 BRANCH=none TEST=with other CLs, build asurada for Zephyr Signed-off-by: Simon Glass <sjg@chromium.org> Change-Id: If2eedaf9100462a9d591525d21bfa76c7e861af1 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2941888 Reviewed-by: Denis Brockus <dbrockus@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 51714e67ff..4fc6705c93 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -328,6 +328,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_SS_MUX
"${PLATFORM_EC}/driver/usb_mux/usb_mux.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_MUX_IT5205
"${PLATFORM_EC}/driver/usb_mux/it5205.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_MUX_PS8743
+ "${PLATFORM_EC}/driver/usb_mux/ps8743.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_MUX_VIRTUAL
"${PLATFORM_EC}/driver/usb_mux/virtual.c")