summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorDiana Z <dzigterman@chromium.org>2021-10-21 15:37:36 -0600
committerCommit Bot <commit-bot@chromium.org>2021-10-25 18:36:10 +0000
commitc5dd2ced732033feab58cab86396f4072c12fc9b (patch)
tree9764cbbde39ea5d549cfa747fef3d9843b6c64d5 /zephyr/CMakeLists.txt
parent95c9d0eab0a2997bef9711fbffaf6a50a76aa093 (diff)
downloadchrome-ec-c5dd2ced732033feab58cab86396f4072c12fc9b.tar.gz
Zephyr: Add PS8818 retimer
Add configs for the PS8818 retimer. BRANCH=None BUG=b:195137794 TEST=zmake testall Signed-off-by: Diana Z <dzigterman@chromium.org> Change-Id: I709ac391da1205eb4c3e8630e4edfc28252114c1 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3238143 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index e864c2d3b8..aff2a77b9f 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -323,6 +323,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_RETIMER_FW_UPDATE
"${PLATFORM_EC}/common/usbc/usb_retimer_fw_update.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_RETIMER_INTEL_BB
"${PLATFORM_EC}/driver/retimer/bb_retimer.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_RETIMER_PS8818
+ "${PLATFORM_EC}/driver/retimer/ps8818.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_SS_MUX
"${PLATFORM_EC}/driver/usb_mux/usb_mux.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_MUX_IT5205