summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Glass <sjg@chromium.org>2021-01-07 15:43:50 -0700
committerCommit Bot <commit-bot@chromium.org>2021-01-09 19:57:34 +0000
commit82e91312b0ceaff0ece097eda0ba376073011ff4 (patch)
tree3c4a122ac7b17e124097dfb5d191485159bf46bd /zephyr/CMakeLists.txt
parent331561a0f81fa6def3a41d1ed6a90de59aa06984 (diff)
downloadchrome-ec-82e91312b0ceaff0ece097eda0ba376073011ff4.tar.gz
zephyr: Add Kconfig options for USB PD alt mode
Allow this feature to be enabled if selected by the board. BUG=b:175434113 BRANCH=none TEST=make BOARD=volteer -j30 With a zephyr-chrome CL, build volteer on zephyr Change-Id: Ie8a3ccc8cf102e3d9313f7b47b39737119a37e2c Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2617040 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 8b0b0f9dbd..258baf4206 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -104,6 +104,9 @@ zephyr_sources_ifdef(CONFIG_PLATFORM_EC_USB_POWER_DELIVERY
"${PLATFORM_EC}/common/usbc/usb_sm.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_USBC_OCP
"${PLATFORM_EC}/common/usbc_ocp.c")
+
+zephyr_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_ALT_MODE_DFP
+ "${PLATFORM_EC}/common/usb_pd_alt_mode_dfp.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_DUAL_ROLE
"${PLATFORM_EC}/common/usb_pd_dual_role.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_HOST_CMD