summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorJeremy Bettis <jbettis@google.com>2021-08-30 12:24:04 -0600
committerCommit Bot <commit-bot@chromium.org>2021-08-31 04:21:58 +0000
commit463618c732f55a80ca533cd601ebea8bfef3494c (patch)
treea3aba3e33bad7fa323508dae3f07d49ee9ec096b /zephyr/CMakeLists.txt
parent79a2b10cc1588a5b5b0b06b93b7fc67c6759546c (diff)
downloadchrome-ec-463618c732f55a80ca533cd601ebea8bfef3494c.tar.gz
zephyr: Build a script to call gcov
In chroot, you can always use llvm-cov to parse the coverage files, but in zephyr sdk, you have to use the right gcov binary for each toolchain. Use cmake to build a gcov shell script, and call it from zmake coverage. BUG=None TEST=zmake coverage in chroot and gitlab BRANCH=None Signed-off-by: Jeremy Bettis <jbettis@google.com> Change-Id: I6203445f0a412193e8280bb5cdf7994d5346fdbd Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3130622 Tested-by: Jeremy Bettis <jbettis@chromium.org> Auto-Submit: Jeremy Bettis <jbettis@chromium.org> Commit-Queue: Yuval Peress <peress@chromium.org> Reviewed-by: Yuval Peress <peress@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index f2550caf84..75076c6edf 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -90,7 +90,9 @@ add_custom_target(
DEPENDS
${ZEPHYR_LIBS_PROPERTY}
kernel
+ ${CMAKE_BINARY_DIR}/gcov.sh
)
+configure_file(gcov.tmpl.sh ${CMAKE_BINARY_DIR}/gcov.sh)
# CONFIG_PLATFORM_EC files that don't relate to something below should be
# included here, sorted by filename. This is common functionality which is