summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Barnaś <mb@semihalf.com>2021-08-09 17:54:36 +0200
committerCommit Bot <commit-bot@chromium.org>2021-08-25 17:26:29 +0000
commit6fc57405b6f9d38edf62824cd2d2fdae1f6e5bbf (patch)
tree945ef3d2a774799a2f71a4a0018eced9cd71a265 /zephyr/CMakeLists.txt
parentd610bce3c3b08e0432f8008c1b4020b173f32e27 (diff)
downloadchrome-ec-6fc57405b6f9d38edf62824cd2d2fdae1f6e5bbf.tar.gz
common: move standard library functions from util.c to another file
This commit moves some of the standard library functions from util.c file to util_stdlib.c file. It will allow to use util.c for both CrOS EC and Zephyr builds and will make shim util file unnecessary. BRANCH=main BUG=b:177096231 TEST=Build both, CrOS EC and Zephyr firmwares Compilation should finish without any problems After flashing, both versions work as they should Change-Id: If6f930a04d28bec35faa16759f43b36176bf3de7 Signed-off-by: Michał Barnaś <mb@semihalf.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3081827 Commit-Queue: Keith Short <keithshort@chromium.org> Reviewed-by: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 171ab973d2..f2550caf84 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -105,6 +105,7 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC "${PLATFORM_EC}/common/base32.c"
"${PLATFORM_EC}/common/queue.c"
"${PLATFORM_EC}/common/shared_mem.c"
"${PLATFORM_EC}/common/uart_printf.c"
+ "${PLATFORM_EC}/common/util.c"
"${PLATFORM_EC}/common/version.c")
# Now include files that depend on or relate to other CONFIG options, sorted by