summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilip Chen <philipchen@google.com>2021-07-01 17:03:20 -0700
committerCommit Bot <commit-bot@chromium.org>2021-07-14 18:06:31 +0000
commitc97cb76b816fc8e02fe3de0652794e85fe38f4c6 (patch)
treee0f3cad98aa4e6f1093374bc7f6fe5dd9e84eadd /zephyr/CMakeLists.txt
parent5236e3b1af983a46fe79a14d353354640c0e89cc (diff)
downloadchrome-ec-c97cb76b816fc8e02fe3de0652794e85fe38f4c6.tar.gz
cbi: Introduce CONFIG_CBI_GPIO
For the boards where SKU_ID/BRD_ID comes from the strapping pins on EC, this new config enables AP to ask EC for those hardware configs using the CBI host command `EC_CMD_GET_CROS_BOARD_INFO`. BRANCH=None BUG=b:186264627 TEST=make buildall -j TEST=Enabled CONFIG_CBI_GPIO for lazor and manually verified with `ectool cbi get`. Change-Id: I7ec9097bab96d2076d9d42db2d003460db000113 Signed-off-by: Philip Chen <philipchen@google.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3002452 Reviewed-by: Keith Short <keithshort@chromium.org> Commit-Queue: Philip Chen <philipchen@chromium.org> Tested-by: Philip Chen <philipchen@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 496c1574ef..51c1b8b7da 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -191,6 +191,9 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGE_RAMP_SW
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CBI_EEPROM
"${PLATFORM_EC}/common/cbi.c"
"${PLATFORM_EC}/common/cbi_eeprom.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CBI_GPIO
+ "${PLATFORM_EC}/common/cbi.c"
+ "${PLATFORM_EC}/common/cbi_gpio.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CONSOLE_CMD_MEM
"${PLATFORM_EC}/common/memory_commands.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_DPTF