summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Barnaś <mb@semihalf.com>2021-05-24 19:53:49 +0200
committerCommit Bot <commit-bot@chromium.org>2021-05-26 16:15:17 +0000
commit965aa277532eb48bb511a56c252a5d6dd182e036 (patch)
tree1320c640b07712ccbe3ce054b2ed7939505d5dcf /zephyr/CMakeLists.txt
parent95034fd21dcd89c0edff5cc2fbf23c06749f09f7 (diff)
downloadchrome-ec-965aa277532eb48bb511a56c252a5d6dd182e036.tar.gz
zephyr: Add IT8XXX drivers to Kconfig
There was no possibility to use ITE_ON_CHIP in zephyr. This commit adds possibility to use it as TCPM. It adds also Kconfigs for IT8XXX2 and IT83XX drivers BUG=b:182500469 BRANCH=none TEST=Manipulate prj.conf to check if drivers are compiled: PLATFORM_EC_USB_PD_TCPM_ITE_ON_CHIP=y PLATFORM_EC_USB_PD_TCPM_DRIVER_IT83XX=y PLATFORM_EC_USB_PD_TCPM_DRIVER_IT8XXX2=y Try building with different options. Eg. enabling drivers without using ITE_ON_CHIP should change nothing in build. Signed-off-by: Michał Barnaś <mb@semihalf.com> Change-Id: I31a9a6899123b855ed82d92b46f023db77714b5a Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2919909 Reviewed-by: Denis Brockus <dbrockus@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 6d542b350b..7e9ae1b342 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -369,6 +369,10 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_TUSB422
"${PLATFORM_EC}/driver/tcpm/tusb422.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_TCPCI
"${PLATFORM_EC}/driver/tcpm/tcpci.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_DRIVER_IT83XX
+ "${PLATFORM_EC}/driver/tcpm/it83xx.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_DRIVER_IT8XXX2
+ "${PLATFORM_EC}/driver/tcpm/it8xxx2.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_PPC
"${PLATFORM_EC}/common/usbc_ppc.c")