summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Barnaś <mb@semihalf.com>2021-08-27 14:45:25 +0200
committerCommit Bot <commit-bot@chromium.org>2021-09-09 15:39:04 +0000
commite2a0670f9db5ecae0396da08c1f36e8b4de60fda (patch)
treef60c1b1af271f53e250ee8982ebade70f358b06e /zephyr/CMakeLists.txt
parent4dadbef9fcbf7033cbe11f4dc71adddf175312c8 (diff)
downloadchrome-ec-e2a0670f9db5ecae0396da08c1f36e8b4de60fda.tar.gz
zephyr: fix compilation of kx022 driver
Add EC root directory to include directories list and fix include directive in kx022 driver info file. BRANCH=main BUG=b:194424288 TEST=Compilation for lazor should work correctly. Change-Id: I1312b4cac8695e61936b9635c7a59c2f59907502 Signed-off-by: Michał Barnaś <mb@semihalf.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3129961 Reviewed-by: Keith Short <keithshort@chromium.org> Commit-Queue: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index e44befc1f1..7dbab86eb9 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -73,6 +73,7 @@ if (DEFINED CONFIG_PLATFORM_EC)
"${PLATFORM_EC}/zephyr/shim/include"
"${PLATFORM_EC}/fuzz"
"${PLATFORM_EC}/test"
+ "${PLATFORM_EC}"
"${PLATFORM_EC}/include"
"${PLATFORM_EC}/include/driver"
"${PLATFORM_EC}/third_party")