summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Glass <sjg@chromium.org>2021-01-14 15:58:10 -0700
committerCommit Bot <commit-bot@chromium.org>2021-01-22 19:09:51 +0000
commit032bc72c4d5b44707f9fb81c3dac2d67ed9a64ac (patch)
treeab6dda6b26de5aba0bf653babc4253974321b3e8 /zephyr/CMakeLists.txt
parenta459eb9cf3c1dc92df1f8e38866ea8d75df88021 (diff)
downloadchrome-ec-032bc72c4d5b44707f9fb81c3dac2d67ed9a64ac.tar.gz
zephyr: Add support for CPU throttling
Add the required Kconfig options to allow this code to be built for Zephyr. Update the mutex since Zephyr needs this to be inited. BUG=b:173787365 BRANCH=none TEST=make BOARD=volteer build zephyr on volteer Change-Id: Ib25808faf82b3f1b2f426ad5f09acb37f1b79d65 Signed-off-by: Simon Glass <sjg@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2631100
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 5b63aca395..55c8e5a138 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -127,6 +127,9 @@ zephyr_sources_ifdef(CONFIG_PLATFORM_EC_POWERSEQ_INTEL
"${PLATFORM_EC}/power/intel_x86.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_POWERSEQ_HOST_SLEEP
"${PLATFORM_EC}/power/host_sleep.c")
+zephyr_sources_ifdef(CONFIG_PLATFORM_EC_THROTTLE_AP
+ "${PLATFORM_EC}/common/throttle_ap.c")
+
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TIMER "${PLATFORM_EC}/common/timer.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_USB_CHARGER