summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorBoris Mittelberg <bmbm@google.com>2021-03-29 23:35:03 +0000
committerCommit Bot <commit-bot@chromium.org>2021-04-27 01:45:46 +0000
commit7307d9e294a9309f152fe5e4adf12854116c0727 (patch)
tree6c34ceecab764ebeb08e789c926cdc95a5585cd0 /zephyr/CMakeLists.txt
parent1221d6fbe3d38141604c44f120c307d5b1f12bda (diff)
downloadchrome-ec-7307d9e294a9309f152fe5e4adf12854116c0727.tar.gz
mkbp: Separate FIFO from the keyboard driver
Move protocol-related functionality out from the keyboard driver. This change is required to allow passing button events via MKBP on devices with non-MKBP keyboards. It reorganizes the code without changing the logic. BUG=b:170966461 BRANCH=main,firmware-dedede-13606.B,firmware-volteer-13672.B-main TEST=None Signed-off-by: Boris Mittelberg <bmbm@google.com> Change-Id: Ifb5b9d8e605f491313ee1dfe2c9950eb52152aa8 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2669355
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index badd503e2f..2b3e0d7233 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -288,7 +288,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_KEYBOARD_PROTOCOL_8042
"${PLATFORM_EC}/common/keyboard_8042.c"
"${PLATFORM_EC}/common/keyboard_8042_sharedlib.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_KEYBOARD_PROTOCOL_MKBP
- "${PLATFORM_EC}/common/keyboard_mkbp.c")
+ "${PLATFORM_EC}/common/keyboard_mkbp.c"
+ "${PLATFORM_EC}/common/mkbp_fifo.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_KEYBOARD_VIVALDI
"${PLATFORM_EC}/common/keyboard_vivaldi.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_PWM_KBLIGHT