summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2021-01-22 16:58:36 -0700
committerCommit Bot <commit-bot@chromium.org>2021-01-26 23:21:35 +0000
commitc10b22901e01e00a9c2c0a5e790a54487f391fe6 (patch)
treee2a6f406c1bd2223183964237288d671cf92c039 /zephyr/CMakeLists.txt
parent061b3ee3a305833e061019744add3f96d5fd1529 (diff)
downloadchrome-ec-c10b22901e01e00a9c2c0a5e790a54487f391fe6.tar.gz
zephyr: Add support for panic output
Add basic panic implementation for Zephyr. Not using any fancy shared or always-on memory for now ... need to resolve how that will be handled later. BUG=b:178011288 BRANCH=none TEST=run various crash commands on volteer, observe output Signed-off-by: Simon Glass <sjg@chromium.org> Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Change-Id: Ia1ce386f738283a2a2b9b60ef7e0bf97f8317837 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2645687
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 3842220085..7a62e4d7e4 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -150,6 +150,7 @@ zephyr_sources_ifdef(CONFIG_PLATFORM_EC_POWERSEQ_INTEL
"${PLATFORM_EC}/power/intel_x86.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_POWERSEQ_HOST_SLEEP
"${PLATFORM_EC}/power/host_sleep.c")
+zephyr_sources_ifdef(CONFIG_PLATFORM_EC_PANIC "${PLATFORM_EC}/common/panic_output.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_THROTTLE_AP
"${PLATFORM_EC}/common/throttle_ap.c")
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TABLET_MODE