summaryrefslogtreecommitdiff
path: root/zephyr/drivers/CMakeLists.txt
diff options
context:
space:
mode:
authorDawid Niedzwiecki <dn@semihalf.com>2021-05-11 13:37:40 +0200
committerCommit Bot <commit-bot@chromium.org>2021-05-14 10:25:25 +0000
commit6e1449eb477f73dbba8bddf4c3dae907a93bb065 (patch)
treea0bf9fae326690f1c4e02f5a1ee950e9eb7e4a2d /zephyr/drivers/CMakeLists.txt
parent4ab13c794e5f5c8a1b85ec08f932e6751f3b4516 (diff)
downloadchrome-ec-6e1449eb477f73dbba8bddf4c3dae907a93bb065.tar.gz
zephyr: Rework CBI to be used as a driver
Rework the CBI support in Zephyr to be used via driver API. Change also approach what to do with SSFC - let sensor drivers decide how to handle alternative sensors. BUG=b:183990188 BRANCH=none TEST=Add alternative motion sensors to the device tree, modify CBI SSFC with 'cbi set 8 value 4', reboot EC and verify that the new sensors are used with the 'accelinfo' command. Signed-off-by: Dawid Niedzwiecki <dn@semihalf.com> Change-Id: I701af96bfa7a17333220530a5c63b8e8aaeb0d6b Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2862727 Reviewed-by: Yuval Peress <peress@chromium.org>
Diffstat (limited to 'zephyr/drivers/CMakeLists.txt')
-rw-r--r--zephyr/drivers/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/drivers/CMakeLists.txt b/zephyr/drivers/CMakeLists.txt
index 5435ee6b84..6ab8383eb5 100644
--- a/zephyr/drivers/CMakeLists.txt
+++ b/zephyr/drivers/CMakeLists.txt
@@ -3,6 +3,7 @@
# found in the LICENSE file.
add_subdirectory(cros_bbram)
+add_subdirectory(cros_cbi)
add_subdirectory(cros_flash)
add_subdirectory(cros_kb_raw)
add_subdirectory(cros_rtc)