summaryrefslogtreecommitdiff
path: root/zephyr/drivers/cros_kb_raw/CMakeLists.txt
diff options
context:
space:
mode:
authorRuibin Chang <Ruibin.Chang@ite.com.tw>2021-03-23 15:20:18 +0800
committerCommit Bot <commit-bot@chromium.org>2021-05-18 15:11:54 +0000
commit70bd26d153cc179aa4f0badef36d04d6e53febb2 (patch)
tree51fc4b7c4e3277930c759a96ab5590bc32bfc035 /zephyr/drivers/cros_kb_raw/CMakeLists.txt
parent9d6b2fb5d861750b5de933327fe555af29f95ea2 (diff)
downloadchrome-ec-70bd26d153cc179aa4f0badef36d04d6e53febb2.tar.gz
zephyr: add support for it8xxx2 cros_kb_row driver
Add support for it8xxx2 cros_kb_row driver. BUG=b:187192587 BRANCH=none TEST=on hayato, console cmd "ksstate" then press key: [115.097839 KB state: -- -- -- 02 -- -- 02 -- -- -- -- -- --] [116.462371 KB state: -- -- -- -- -- -- 02 -- -- -- -- -- --] [116.499633 KB state: -- -- -- -- -- -- -- -- -- -- -- -- --] Cq-Depend: chromium:2902165 Change-Id: I067b95bf2dfe4978e5370ce27382c67db100467b Signed-off-by: Ruibin Chang <Ruibin.Chang@ite.com.tw> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2784322 Reviewed-by: Keith Short <keithshort@chromium.org> Commit-Queue: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/drivers/cros_kb_raw/CMakeLists.txt')
-rw-r--r--zephyr/drivers/cros_kb_raw/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/drivers/cros_kb_raw/CMakeLists.txt b/zephyr/drivers/cros_kb_raw/CMakeLists.txt
index 54b8c63b0f..a9ef2b4bb2 100644
--- a/zephyr/drivers/cros_kb_raw/CMakeLists.txt
+++ b/zephyr/drivers/cros_kb_raw/CMakeLists.txt
@@ -1,3 +1,4 @@
# SPDX-License-Identifier: Apache-2.0
zephyr_library_sources_ifdef(CONFIG_CROS_KB_RAW_NPCX cros_kb_raw_npcx.c)
+zephyr_library_sources_ifdef(CONFIG_CROS_KB_RAW_ITE cros_kb_raw_ite.c)