summaryrefslogtreecommitdiff
path: root/zephyr/emul/CMakeLists.txt
diff options
context:
space:
mode:
authorTomasz Michalec <tm@semihalf.com>2021-07-20 12:28:40 +0200
committerCommit Bot <commit-bot@chromium.org>2021-07-27 18:32:39 +0000
commitf4047a0646f11dee2f9c33a78c6dd2009affd81f (patch)
tree9f092b100c93e756633dd5240a3f8402fcdbab68 /zephyr/emul/CMakeLists.txt
parent07ecd26158f67190ff36dd550220160e684aaa33 (diff)
downloadchrome-ec-f4047a0646f11dee2f9c33a78c6dd2009affd81f.tar.gz
zephyr: Add TCS3400 emulator
Add TCS3400 emulator which is emulated device on i2c bus. Emulator properties can be defined using device tree or runtime TCS emulator API. It allows to set custom handlers for write and read messages. Emulator is able to convert internal values to register values that can be obtained by driver through i2c interface. Conversion takes current state set by driver into account (gain and data acquisition time). BUG=b:184856080 BRANCH=none TEST=none Signed-off-by: Tomasz Michalec <tm@semihalf.com> Change-Id: I16f25de43e047df39f84ce86044736d50c9a49c8 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3048094 Reviewed-by: Simon Glass <sjg@chromium.org>
Diffstat (limited to 'zephyr/emul/CMakeLists.txt')
-rw-r--r--zephyr/emul/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/emul/CMakeLists.txt b/zephyr/emul/CMakeLists.txt
index d0d4bce0f1..500d1e8b2f 100644
--- a/zephyr/emul/CMakeLists.txt
+++ b/zephyr/emul/CMakeLists.txt
@@ -9,3 +9,4 @@ zephyr_library_sources_ifdef(CONFIG_EMUL_PPC_SYV682X emul_syv682x.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_BMI emul_bmi.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_BMI emul_bmi160.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_BMI emul_bmi260.c)
+zephyr_library_sources_ifdef(CONFIG_EMUL_TCS3400 emul_tcs3400.c)