summaryrefslogtreecommitdiff
path: root/zephyr/emul/CMakeLists.txt
diff options
context:
space:
mode:
authorTomasz Michalec <tm@semihalf.com>2021-06-22 11:09:31 +0200
committerCommit Bot <commit-bot@chromium.org>2021-07-14 21:24:50 +0000
commit3d41adc1d1d13a76b68f7927caa37315ed90977e (patch)
treeec679e13f5ec35281fea6e852fa38783ccc5fbad /zephyr/emul/CMakeLists.txt
parent58e9704c8f823bebbf2ae426567dd95a8eef6d50 (diff)
downloadchrome-ec-3d41adc1d1d13a76b68f7927caa37315ed90977e.tar.gz
zephyr: Add BMI160 emulator
Add BMI emulator which is emulated device on i2c bus. Emulated accelerometer and gyroscope properties are defined through device tree, but they can be changed in runtime through BMI emulator API. It allows to set custom handlers for write and read messages to emulate more complex scenarios or malfunctioning device. BMI emulator is designed to implement support for different BMI models as an extension to common emulator code. BUG=b:184856157 BRANCH=none TEST=none Signed-off-by: Tomasz Michalec <tm@semihalf.com> Change-Id: I63e9d3aca98c8923372437f7a66257a4c82817f2 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2977559 Reviewed-by: Simon Glass <sjg@chromium.org> Reviewed-by: Jeremy Bettis <jbettis@chromium.org>
Diffstat (limited to 'zephyr/emul/CMakeLists.txt')
-rw-r--r--zephyr/emul/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/emul/CMakeLists.txt b/zephyr/emul/CMakeLists.txt
index fc91a74e21..763372cddc 100644
--- a/zephyr/emul/CMakeLists.txt
+++ b/zephyr/emul/CMakeLists.txt
@@ -6,3 +6,5 @@ zephyr_library_sources_ifdef(CONFIG_EMUL_SMART_BATTERY emul_smart_battery.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_BMA255 emul_bma255.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_BC12_DETECT_PI3USB9201 emul_pi3usb9201.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_PPC_SYV682X emul_syv682x.c)
+zephyr_library_sources_ifdef(CONFIG_EMUL_BMI emul_bmi.c)
+zephyr_library_sources_ifdef(CONFIG_EMUL_BMI emul_bmi160.c)