summaryrefslogtreecommitdiff
path: root/zephyr/emul/CMakeLists.txt
diff options
context:
space:
mode:
authorTing Shen <phoenixshen@google.com>2022-08-11 16:34:41 +0800
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-08-18 11:53:01 +0000
commit51f7655278b14234de81854d4e17b5bfae25f7d5 (patch)
tree668373d98a9afbc3f17244d21f5c55f7d84c249f /zephyr/emul/CMakeLists.txt
parent90dc1ec704298576cc2343e2c24ff63cf948b560 (diff)
downloadchrome-ec-51f7655278b14234de81854d4e17b5bfae25f7d5.tar.gz
zephyr: test: implement pwm_mock driver
Implement a mock pwm device for testing pwm_led driver. This driver supports 1 channel, and an extra get_duty function for verification. BUG=b:241064591 TEST=passed the new test in CL:3792590 BRANCH=none Signed-off-by: Ting Shen <phoenixshen@google.com> Change-Id: Ife27e29bd615f37733b3592c9c8b0a6df61defb0 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3825344 Commit-Queue: Ting Shen <phoenixshen@chromium.org> Code-Coverage: Zoss <zoss-cl-coverage@prod.google.com> Reviewed-by: Jeremy Bettis <jbettis@chromium.org> Tested-by: Ting Shen <phoenixshen@chromium.org>
Diffstat (limited to 'zephyr/emul/CMakeLists.txt')
-rw-r--r--zephyr/emul/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/emul/CMakeLists.txt b/zephyr/emul/CMakeLists.txt
index 4b64e80736..b1371724e4 100644
--- a/zephyr/emul/CMakeLists.txt
+++ b/zephyr/emul/CMakeLists.txt
@@ -22,5 +22,6 @@ zephyr_library_sources_ifdef(CONFIG_EMUL_CLOCK_CONTROL emul_clock_control.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_SN5S330 emul_sn5s330.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_KB_RAW emul_kb_raw.c)
zephyr_library_sources_ifdef(CONFIG_EMUL_CROS_FLASH emul_flash.c)
+zephyr_library_sources_ifdef(CONFIG_PWM_MOCK pwm_mock.c)
cros_ec_library_include_directories_ifdef(CONFIG_EMUL_CROS_FLASH include)