summaryrefslogtreecommitdiff
path: root/zephyr/linker/CMakeLists.txt
diff options
context:
space:
mode:
authorFabio Baltieri <fabiobaltieri@google.com>2021-07-08 18:07:06 +0000
committerCommit Bot <commit-bot@chromium.org>2021-08-10 21:53:32 +0000
commit64cda0a13de4056c13c8a62b756008480be6b425 (patch)
tree481f342135e489db5603903326e342ef06a2c5c8 /zephyr/linker/CMakeLists.txt
parent2e9af0c566b905d2aa5c5d1bd7c692e549929ff1 (diff)
downloadchrome-ec-64cda0a13de4056c13c8a62b756008480be6b425.tar.gz
zephyr: shim: reimplement hooks using iterables
Reimplement the hooks shim code using Zephyr iterable sections. Keep the existing hook_registry based structure, gets rid of the per-hook init functions and instead initializes all the list nodes from a single init call. BRANCH=none BUG=b:195521227 TEST=build and run on volteer Signed-off-by: Fabio Baltieri <fabiobaltieri@google.com> Change-Id: Ic166d214ee1dcd1431ec484e5014cb297f7fb8c2 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3069399 Reviewed-by: Keith Short <keithshort@chromium.org> Reviewed-by: Jack Rosenthal <jrosenth@chromium.org> Commit-Queue: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/linker/CMakeLists.txt')
-rw-r--r--zephyr/linker/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/linker/CMakeLists.txt b/zephyr/linker/CMakeLists.txt
index 316dcc71be..71955c6d9d 100644
--- a/zephyr/linker/CMakeLists.txt
+++ b/zephyr/linker/CMakeLists.txt
@@ -15,4 +15,5 @@ zephyr_linker_sources(RAM_SECTIONS image_size.ld)
zephyr_linker_sources_ifdef(CONFIG_SOC_FAMILY_NPCX ROM_START SORT_KEY 1
npcx-lfw.ld)
+zephyr_linker_sources(DATA_SECTIONS iterables-ram.ld)
zephyr_linker_sources(SECTIONS iterables-rom.ld)