summaryrefslogtreecommitdiff
path: root/zephyr/projects/herobrine/CMakeLists.txt
diff options
context:
space:
mode:
authorWai-Hong Tam <waihong@google.com>2022-02-25 09:54:38 -0800
committerCommit Bot <commit-bot@chromium.org>2022-02-25 23:13:39 +0000
commit3d7353e99d86a13e2c2aade847ef44a2ad5f3776 (patch)
tree91c9f10f25ea01fd0ade915377d2fc2bdd6e46ad /zephyr/projects/herobrine/CMakeLists.txt
parent8047a4185b4b6176069782b27a1051a5252e5ac0 (diff)
downloadchrome-ec-3d7353e99d86a13e2c2aade847ef44a2ad5f3776.tar.gz
villager: Create initial Villager EC image
Fork the Villager build from the Herobrine's. These 2 images are the same so far except the runtime Herobrine-specific component swap, which depends on the CONFIG_BOARD_HEROBRINE. The villager image doesn't care about the BOARD ID and just uses the static configs. More changes will be added later. BRANCH=None BUG=b:221444985 TEST=Built the villager EC image. Change-Id: I0c8d71c4b664d6c8b80e94debab0cccf79030778 Signed-off-by: Wai-Hong Tam <waihong@google.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3489825 Reviewed-by: Keith Short <keithshort@chromium.org> Commit-Queue: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/projects/herobrine/CMakeLists.txt')
-rw-r--r--zephyr/projects/herobrine/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/projects/herobrine/CMakeLists.txt b/zephyr/projects/herobrine/CMakeLists.txt
index 42752bcb50..64102e951c 100644
--- a/zephyr/projects/herobrine/CMakeLists.txt
+++ b/zephyr/projects/herobrine/CMakeLists.txt
@@ -23,4 +23,6 @@ if(DEFINED CONFIG_BOARD_HEROBRINE)
"src/herobrine/alt_dev_replacement.c")
elseif(DEFINED CONFIG_BOARD_HOGLIN)
project(hoglin)
+elseif(DEFINED CONFIG_BOARD_VILLAGER)
+ project(villager)
endif()