summaryrefslogtreecommitdiff
path: root/zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Barnaś <mb@semihalf.com>2021-08-19 15:05:54 +0200
committerCommit Bot <commit-bot@chromium.org>2021-09-03 21:31:06 +0000
commit017ff2201868caa3d55e3e929a070533693f8148 (patch)
treee1142bc2e21683b1d1bdab27d2b18b3fd6449ab6 /zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt
parent5dd50874e1f4b1f0c47d7245daabb68a4414f0ba (diff)
downloadchrome-ec-017ff2201868caa3d55e3e929a070533693f8148.tar.gz
zephyr: define herobrine's batteries in device tree
This commit adds herobrine's batteries definitions to device tree and removes old battery.c usage in Zephyr. BRANCH=main BUG=b:183544739 TEST=Compile and flash Zephyr, battery should be detected correctly and its model should be logged in EC console. Change-Id: I1783715b72863fb947077f8dbde396071433bb44 Signed-off-by: Michał Barnaś <mb@semihalf.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3107388 Reviewed-by: Keith Short <keithshort@chromium.org> Commit-Queue: Keith Short <keithshort@chromium.org> Tested-by: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt')
-rw-r--r--zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt b/zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt
index e6ac68192b..dfccaf12c6 100644
--- a/zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt
+++ b/zephyr/projects/herobrine/herobrine_npcx9/CMakeLists.txt
@@ -17,6 +17,3 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_COMMON
"src/led.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_I2C
"src/i2c.c")
-
-zephyr_library_sources(
- "src/battery.c")