summaryrefslogtreecommitdiff
path: root/zephyr/projects/kohaku/CMakeLists.txt
diff options
context:
space:
mode:
authorYuval Peress <peress@chromium.org>2021-01-29 10:06:04 -0700
committerCommit Bot <commit-bot@chromium.org>2021-01-30 03:13:30 +0000
commit43a04f67d05d275d8e3927697965311eabe9357c (patch)
tree48a8f55cda2cfede971100aef04520281c6a07d1 /zephyr/projects/kohaku/CMakeLists.txt
parente333c591d764b95d0377fb2886c8b688e6bf43ac (diff)
downloadchrome-ec-43a04f67d05d275d8e3927697965311eabe9357c.tar.gz
zephyr: kohaku: Update build for flash
The build for Kohaku needed to add the include/drivers directory so that system calls can be generated (this mirrors volteer). Additionally, since kohaku isn't upstreamed, it needed the CONFIG_FLASH_SIZE value. BRANCH=none BUG=b:176828988, b:174481378 TEST=zmake testall Signed-off-by: Yuval Peress <peress@chromium.org> Change-Id: I19989e85e22360e12c0dc0ee29b6769673023a22 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2659679 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/projects/kohaku/CMakeLists.txt')
-rw-r--r--zephyr/projects/kohaku/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/zephyr/projects/kohaku/CMakeLists.txt b/zephyr/projects/kohaku/CMakeLists.txt
index a9dc7e910b..338e936f46 100644
--- a/zephyr/projects/kohaku/CMakeLists.txt
+++ b/zephyr/projects/kohaku/CMakeLists.txt
@@ -3,6 +3,16 @@
# found in the LICENSE file.
cmake_minimum_required(VERSION 3.13.1)
+
+# Append ${PLATFORM_EC}/zephyr/include/drivers to SYSCALL_INCLUDE_DIRS
+# variable for generating __syscall api functions by the
+# `gen_syscalls.py` script.
+# TODO: remove this when zmake support
+list(APPEND
+ SYSCALL_INCLUDE_DIRS
+ "${CMAKE_CURRENT_LIST_DIR}/../../include/drivers"
+)
+
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(kohaku)