summaryrefslogtreecommitdiff
path: root/zephyr/projects/skyrim/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Short <keithshort@chromium.org>2022-02-11 13:27:26 -0700
committerCommit Bot <commit-bot@chromium.org>2022-02-25 21:10:09 +0000
commit3ba28b0c41e898d03afcc9432f812fa8e5a9524a (patch)
tree911c4e849c7b2656746077b8e47764c685fd984e /zephyr/projects/skyrim/CMakeLists.txt
parent84fd17247ac8d55ae4adb67281841a9a2a4c2433 (diff)
downloadchrome-ec-3ba28b0c41e898d03afcc9432f812fa8e5a9524a.tar.gz
zephyr: split legacy and shimmed codes into libraries
Split the legacy EC code and shimmed code into separate libraries. This allows for declaring different compiler definitions to the legacy and shim code. BUG=b:218856245 BRANCH=none TEST=zmake testall Signed-off-by: Keith Short <keithshort@chromium.org> Change-Id: Ice25c21409d33594e7d465092ad5066be7336dbe Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3489101 Reviewed-by: Denis Brockus <dbrockus@chromium.org>
Diffstat (limited to 'zephyr/projects/skyrim/CMakeLists.txt')
-rw-r--r--zephyr/projects/skyrim/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/zephyr/projects/skyrim/CMakeLists.txt b/zephyr/projects/skyrim/CMakeLists.txt
index 52146af60c..b364421eb4 100644
--- a/zephyr/projects/skyrim/CMakeLists.txt
+++ b/zephyr/projects/skyrim/CMakeLists.txt
@@ -7,8 +7,8 @@ cmake_minimum_required(VERSION 3.13.1)
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(guybrush)
-zephyr_library_include_directories_ifdef(CONFIG_BOARD_SKYRIM include)
-zephyr_library_include_directories_ifdef(CONFIG_BOARD_GUYBRUSH include_guybrush)
+cros_ec_library_include_directories_ifdef(CONFIG_BOARD_SKYRIM include)
+cros_ec_library_include_directories_ifdef(CONFIG_BOARD_GUYBRUSH include_guybrush)
zephyr_library_sources_ifdef(CONFIG_BOARD_SKYRIM "power_signals.c")
zephyr_library_sources_ifdef(CONFIG_BOARD_GUYBRUSH "power_signals_guybrush.c")