summaryrefslogtreecommitdiff
path: root/zephyr/projects/skyrim/CMakeLists.txt
diff options
context:
space:
mode:
authorYu-An Chen <yu-an.chen@quanta.corp-partner.google.com>2022-08-26 17:07:34 +0800
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-09-01 02:34:21 +0000
commit4ebd39c76300382b14f6614cc5d7993545d4b99e (patch)
tree1b05b9e5fdb7d1e5f63b353fce4041a6b4b810ea /zephyr/projects/skyrim/CMakeLists.txt
parent52e2c367a9c61c22201a8f477c76ed5d9467e8fe (diff)
downloadchrome-ec-4ebd39c76300382b14f6614cc5d7993545d4b99e.tar.gz
morthal: Initial EC image
Create the initial Zephyr EC image for the morthal variant by copying the skyrim reference board EC files. More changes will be added later. BUG=none TEST=zmake build morthal BRANCH=none Signed-off-by: Yu-An Chen <yu-an.chen@quanta.corp-partner.google.com> Change-Id: I358b649c4674003c8531bcef4f7ea8727293141b Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3858969 Reviewed-by: Moises Garcia <moisesgarcia@google.com> Tested-by: Yu-An Chen <yu-an.chen@quanta.corp-partner.google.com> Auto-Submit: Yu-An Chen <yu-an.chen@quanta.corp-partner.google.com> Reviewed-by: Diana Z <dzigterman@chromium.org> Commit-Queue: Yu-An Chen <yu-an.chen@quanta.corp-partner.google.com>
Diffstat (limited to 'zephyr/projects/skyrim/CMakeLists.txt')
-rw-r--r--zephyr/projects/skyrim/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/zephyr/projects/skyrim/CMakeLists.txt b/zephyr/projects/skyrim/CMakeLists.txt
index 8b706417e4..24d0138bc9 100644
--- a/zephyr/projects/skyrim/CMakeLists.txt
+++ b/zephyr/projects/skyrim/CMakeLists.txt
@@ -17,6 +17,13 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_AMD_STT
"stt.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_FAN "fan.c")
+if(DEFINED CONFIG_BOARD_MORTHAL)
+ project(morthal)
+ zephyr_library_sources(
+ "usbc_config.c"
+)
+endif()
+
if(DEFINED CONFIG_BOARD_SKYRIM)
project(skyrim)
cros_ec_library_include_directories_ifdef(CONFIG_BOARD_SKYRIM include)