summaryrefslogtreecommitdiff
path: root/zephyr/shim/CMakeLists.txt
diff options
context:
space:
mode:
authorYuval Peress <peress@chromium.org>2021-02-12 13:33:48 -0700
committerCommit Bot <commit-bot@chromium.org>2021-02-17 22:57:46 +0000
commit717b8cb62ba1d15ce070ffb35474184672ed8010 (patch)
tree4ff89109907ecae23707dba5bc545b1448f7a27d /zephyr/shim/CMakeLists.txt
parent0403bb098edd006d4c0c1b483e8ba591af21b91c (diff)
downloadchrome-ec-717b8cb62ba1d15ce070ffb35474184672ed8010.tar.gz
zephyr: cortex-m: Add software panic support
Software panic implementation is needed to support system.c's system_common_pre_init. For reference, this code was taken from core/cortex-m/panic.c. BRANCH=none BUG=b:167392037 TEST=zmake testall Change-Id: I91232b297c9933d48e3b7c59d7d8befe84cdecc5 Signed-off-by: Yuval Peress <peress@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2693687 Reviewed-by: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/shim/CMakeLists.txt')
-rw-r--r--zephyr/shim/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/zephyr/shim/CMakeLists.txt b/zephyr/shim/CMakeLists.txt
index 3add679c23..e36101756a 100644
--- a/zephyr/shim/CMakeLists.txt
+++ b/zephyr/shim/CMakeLists.txt
@@ -2,5 +2,6 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-add_subdirectory("src")
add_subdirectory("chip")
+add_subdirectory("core")
+add_subdirectory("src")