summaryrefslogtreecommitdiff
path: root/zephyr/shim/chip/it8xxx2/CMakeLists.txt
diff options
context:
space:
mode:
authorDenis Brockus <dbrockus@google.com>2021-04-23 10:24:33 -0600
committerCommit Bot <commit-bot@chromium.org>2021-04-23 18:43:07 +0000
commitf9ff5bda427aa103191beafc99be1552aedce1d8 (patch)
treeb27e14b4437777734ad48146f223bc55137a42e2 /zephyr/shim/chip/it8xxx2/CMakeLists.txt
parentb5e952d4be046f66f49a40bed004f4646e509da9 (diff)
downloadchrome-ec-f9ff5bda427aa103191beafc99be1552aedce1d8.tar.gz
zephyr: shim: chip/it9xxx2: add pinmux shim
This is a temporary piece of code that will be adjusted and/or removed when driver/pinmux/pinmux_ite_it8xxx2.c is released. The temporary code allows UART to work, so it is being added for now. BUG=b:185202623 BRANCH=none TEST=none Signed-off-by: Denis Brockus <dbrockus@google.com> Change-Id: I3f100f6a4cefea86f1e00a0a542ccd7f38f44878 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2848434 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org> Commit-Queue: Jack Rosenthal <jrosenth@chromium.org> Tested-by: Jack Rosenthal <jrosenth@chromium.org> Tested-by: Denis Brockus <dbrockus@chromium.org> Auto-Submit: Denis Brockus <dbrockus@chromium.org>
Diffstat (limited to 'zephyr/shim/chip/it8xxx2/CMakeLists.txt')
-rw-r--r--zephyr/shim/chip/it8xxx2/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/shim/chip/it8xxx2/CMakeLists.txt b/zephyr/shim/chip/it8xxx2/CMakeLists.txt
index d9772127d7..9641bce573 100644
--- a/zephyr/shim/chip/it8xxx2/CMakeLists.txt
+++ b/zephyr/shim/chip/it8xxx2/CMakeLists.txt
@@ -3,3 +3,4 @@
# found in the LICENSE file.
zephyr_library_sources_ifdef(CONFIG_CROS_EC system.c)
+zephyr_library_sources_ifdef(CONFIG_CROS_EC pinmux.c)