summaryrefslogtreecommitdiff
path: root/zephyr/shim/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDawid Niedzwiecki <dn@semihalf.com>2021-02-17 12:15:21 +0100
committerCommit Bot <commit-bot@chromium.org>2021-02-23 19:29:13 +0000
commita5a81dca4579961b9d78c7c85442d76b3c87dbbb (patch)
treec702e09f5137ecab4b8b69b5982543bf9a9f3e63 /zephyr/shim/src/CMakeLists.txt
parent25fa055c3ecd98c5d339cc4002054c584f99cb1b (diff)
downloadchrome-ec-a5a81dca4579961b9d78c7c85442d76b3c87dbbb.tar.gz
zephyr: add shim thermal support
Add thermal support to Zephyr which includes handling temperature threshold for certain events. The thresholds are defined in the dts file as temperature sensor parameters - there are limits per temperature sensor. The struct ec_thermal_config thermal_params[] array with all parameters is generated automatically based on named_temp_sensors node. Enable "thermalget" and "thermalset" console commands along with EC_CMD_THERMAL_GET_THRESHOLD and EC_CMD_THERMAL_SET_THRESHOLD host commands. Also, add a few functions to utils needed to verify if an event occurred (falling/rising edge). BUG=b:179886912 BRANCH=none TEST=build Zephyr TEST=Run "thermalget" command to check current thresholds. Change the thresholds with "thermalset" to verify if AP throttling is requested. Signed-off-by: Dawid Niedzwiecki <dn@semihalf.com> Change-Id: I5f527ceecab2427b3034fd8baa62bb8482f99ff3 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2698845 Reviewed-by: Simon Glass <sjg@chromium.org>
Diffstat (limited to 'zephyr/shim/src/CMakeLists.txt')
-rw-r--r--zephyr/shim/src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/zephyr/shim/src/CMakeLists.txt b/zephyr/shim/src/CMakeLists.txt
index 38955f65d4..0311299074 100644
--- a/zephyr/shim/src/CMakeLists.txt
+++ b/zephyr/shim/src/CMakeLists.txt
@@ -27,7 +27,8 @@ zephyr_sources_ifdef(CONFIG_PLATFORM_EC_MPU mpu.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_PANIC panic.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_PWM pwm.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_RTC rtc.c)
-zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TEMP_SENSOR temp_sensors.c)
+zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TEMP_SENSOR temp_sensors.c
+ thermal.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TIMER hwtimer.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_I2C i2c.c)
zephyr_sources_ifdef(CONFIG_SHIMMED_TASKS tasks.c)