summaryrefslogtreecommitdiff
path: root/zephyr/shim/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2020-09-23 08:26:42 -0600
committerCommit Bot <commit-bot@chromium.org>2020-10-01 19:14:34 +0000
commitee4037ea734103169bd1cae24ab3b6a5e2e71f67 (patch)
tree9d5cee6b4d01b099e38822443bef181990cf81ce /zephyr/shim/src/CMakeLists.txt
parent1434fa7a1d5fed910c86f479aab75fee6521bb5d (diff)
downloadchrome-ec-ee4037ea734103169bd1cae24ab3b6a5e2e71f67.tar.gz
zephyr: shim in the zephyr shell as the EC console
This provides compatible macros for DECLARE_CONSOLE_COMMAND, DECLARE_SAFE_CONSOLE_COMMAND, and DECLARE_CONSOLE_COMMAND_FLAGS. Note: the concept of command flags and command restriction are not enabled currently for Zephyr. We simply define everything for now. These macros use the Zephyr shell subsystem as the backend for commands. In addition, cprints, cprintf, and cputs have been redirected to the shell for CC_CONSOLE channel outputs, and printk for all other outputs. We will look at using Zephyr's logging subsystem instead of printk for the other channels in the future. BUG=b:167590251 BRANCH=none TEST=run "gettime" and "timerinfo" commands with follow-up CLs Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Change-Id: I17caedcd0b84a21dd2b135312f683885eaf694af Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2427097 Reviewed-by: Jett Rink <jettrink@chromium.org>
Diffstat (limited to 'zephyr/shim/src/CMakeLists.txt')
-rw-r--r--zephyr/shim/src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/zephyr/shim/src/CMakeLists.txt b/zephyr/shim/src/CMakeLists.txt
index d3db874f71..0d54d82ad0 100644
--- a/zephyr/shim/src/CMakeLists.txt
+++ b/zephyr/shim/src/CMakeLists.txt
@@ -2,4 +2,4 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-# Nothing here yet.
+zephyr_sources(console.c)