summaryrefslogtreecommitdiff
path: root/zephyr/shim/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2020-11-11 12:30:51 -0700
committerCommit Bot <commit-bot@chromium.org>2020-11-20 20:32:32 +0000
commit4e1da5433feb066465bf49df13c1ec0995941e3f (patch)
tree6979d35e22732d5400481bbf1ad2cd803e346125 /zephyr/shim/src/CMakeLists.txt
parent0be00eec2444f1c40ff0e39c0a35c55d46798885 (diff)
downloadchrome-ec-4e1da5433feb066465bf49df13c1ec0995941e3f.tar.gz
zephyr: shim some basic eSPI functionality
Add some basic functionality to get and set virtual wires. BUG=b:171815541 BRANCH=none TEST=volteer power sequencing to S0 (requires follow-up CLs) Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Change-Id: I07655fd3a768aca962112a98d6f1f593633eb605 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2548307 Reviewed-by: Jett Rink <jettrink@chromium.org>
Diffstat (limited to 'zephyr/shim/src/CMakeLists.txt')
-rw-r--r--zephyr/shim/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/shim/src/CMakeLists.txt b/zephyr/shim/src/CMakeLists.txt
index b3a828b412..a8f9a636d5 100644
--- a/zephyr/shim/src/CMakeLists.txt
+++ b/zephyr/shim/src/CMakeLists.txt
@@ -7,6 +7,7 @@ zephyr_sources(gpio.c)
zephyr_sources(util.c)
zephyr_sources(crc.c)
+zephyr_sources_ifdef(CONFIG_PLATFORM_EC_ESPI espi.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_HOOKS hooks.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TIMER hwtimer.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_I2C i2c.c)