summaryrefslogtreecommitdiff
path: root/zephyr/shim/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJett Rink <jettrink@chromium.org>2020-10-01 15:52:04 -0600
committerCommit Bot <commit-bot@chromium.org>2020-10-12 23:13:49 +0000
commitb63257f8641c9f3c9497ee2847ac68032dc6b707 (patch)
treec064b5b9b6d1468cbf59f2febb54b01740dfb380 /zephyr/shim/src/CMakeLists.txt
parent9dfd286309e0b43a905bf77a56923d29027f505b (diff)
downloadchrome-ec-b63257f8641c9f3c9497ee2847ac68032dc6b707.tar.gz
zephyr: add strtoi shim function
When I compile volteer, I only need one stdlib style function and it is something we made ourselves. There is a long verion in Zephyr and long and int are the same size for 32-bit MCUs so we just need to forward the implementation. Also remove compilation of our existing platform/ec util file since Zephyr already provides these basic stdlib like functions. BRANCH=none BUG=b:169935794 TEST=Run Zephyr image on Volteer using this function. TEST=Build and run posix-ec target as well Change-Id: Idb4ea4d5e0a6ad3da8ddc5781e16aeb6e666d85f Signed-off-by: Jett Rink <jettrink@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2444371 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/shim/src/CMakeLists.txt')
-rw-r--r--zephyr/shim/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/zephyr/shim/src/CMakeLists.txt b/zephyr/shim/src/CMakeLists.txt
index 5f8eaf88ad..f87b114949 100644
--- a/zephyr/shim/src/CMakeLists.txt
+++ b/zephyr/shim/src/CMakeLists.txt
@@ -3,4 +3,5 @@
# found in the LICENSE file.
zephyr_sources(console.c)
+zephyr_sources(util.c)
zephyr_sources_ifdef(CONFIG_PLATFORM_EC_TIMER hwtimer.c)