summaryrefslogtreecommitdiff
path: root/zephyr/subsys/CMakeLists.txt
diff options
context:
space:
mode:
authorDivya Sasidharan <divya.s.sasidharan@intel.com>2022-01-07 10:37:51 -0800
committerCommit Bot <commit-bot@chromium.org>2022-02-14 20:11:50 +0000
commit2826cac033b6233a96792af9c7171e61fda5e5ac (patch)
tree28e06bb085fda44a12454a85fce5fa5cc8dae532 /zephyr/subsys/CMakeLists.txt
parentb10b4e0a16b8310e6bd7786615b0497044946eca (diff)
downloadchrome-ec-2826cac033b6233a96792af9c7171e61fda5e5ac.tar.gz
zephyr: subsys/ap_pwrseq: Add inbuilt power sequencing support
Add inbuilt AP power sequencing support. This patch adds power up sequence for AP. Built on top of below reference: https://github.com/zephyrproject-rtos/zephyr/pull/29245 TODO: * b:216764983: Create separate .yaml for common and chipset specific GPIOS. * b:217952699: Subsys to driver model, override to callback implementation change. BUG=b:203446068 BRANCH=None TEST=zmake testall; make buildall; brya boots up to S0 and display is up. Change-Id: I84ce803d4e1b4594dc3f61bd2d8bcd1f94fd2be8 Signed-off-by: Divya Sasidharan <divya.s.sasidharan@intel.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3377810 Reviewed-by: Peter Marheine <pmarheine@chromium.org> Reviewed-by: Andrew McRae <amcrae@google.com>
Diffstat (limited to 'zephyr/subsys/CMakeLists.txt')
-rw-r--r--zephyr/subsys/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/zephyr/subsys/CMakeLists.txt b/zephyr/subsys/CMakeLists.txt
new file mode 100644
index 0000000000..4e1389b729
--- /dev/null
+++ b/zephyr/subsys/CMakeLists.txt
@@ -0,0 +1,3 @@
+# SPDX-License-Identifier: Apache-2.0
+
+add_subdirectory_ifdef(CONFIG_AP_PWRSEQ ap_pwrseq)