summaryrefslogtreecommitdiff
path: root/zephyr/test/base32/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Fagerburg <pfagerburg@google.com>2021-01-22 16:59:50 -0700
committerCommit Bot <commit-bot@chromium.org>2021-01-25 20:55:46 +0000
commitbfc29b475e280e442fed7a234d1b381f0dd70ec6 (patch)
treee11249eb078a33af31e4bfcca2554f21c35e330d /zephyr/test/base32/CMakeLists.txt
parent0f7a6d893cd3ae751a587d763e8d01394b69255e (diff)
downloadchrome-ec-bfc29b475e280e442fed7a234d1b381f0dd70ec6.tar.gz
zephyr: test: update unit tests for zmake
Many of the options in CMakeLists.txt and prj.conf are no longer necessary with zmake and Kconfig handling them automatically now. BUG=b:178220157 BRANCH=none TEST=`zmake testall` Signed-off-by: Paul Fagerburg <pfagerburg@google.com> Change-Id: I845f42c4b51214f28ab7771734232fec763c04f4 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2645696 Commit-Queue: Paul Fagerburg <pfagerburg@chromium.org> Commit-Queue: Jack Rosenthal <jrosenth@chromium.org> Tested-by: Paul Fagerburg <pfagerburg@chromium.org> Reviewed-by: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/test/base32/CMakeLists.txt')
-rw-r--r--zephyr/test/base32/CMakeLists.txt20
1 files changed, 3 insertions, 17 deletions
diff --git a/zephyr/test/base32/CMakeLists.txt b/zephyr/test/base32/CMakeLists.txt
index 6ae6f232a9..674ad0d244 100644
--- a/zephyr/test/base32/CMakeLists.txt
+++ b/zephyr/test/base32/CMakeLists.txt
@@ -1,23 +1,9 @@
-# SPDX-License-Identifier: Apache-2.0
+# Copyright 2021 The Chromium OS Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
cmake_minimum_required(VERSION 3.13.1)
-set(BOARD native_posix)
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(base32)
-# Need to ensure that we are including only zephyr definitions in include files
-# We cannot set these via kconfig, since this unit test does not bring in the
-# zephyr-chrome repository
-zephyr_compile_definitions("CONFIG_ZEPHYR")
-
-# We need to include the EC include directory and this local test directory
-# for the task defines
-zephyr_include_directories(
- "${PLATFORM_EC}/zephyr/shim/include"
- "${PLATFORM_EC}/fuzz"
- "${PLATFORM_EC}/test"
- "${PLATFORM_EC}/include")
-
-# Include test file, test under test and console dependency
target_sources(app PRIVATE "${PLATFORM_EC}/test/base32.c")
-target_sources(app PRIVATE "${PLATFORM_EC}/common/base32.c")