summaryrefslogtreecommitdiff
path: root/zephyr/test/i2c/CMakeLists.txt
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2020-12-14 16:30:26 -0700
committerCommit Bot <commit-bot@chromium.org>2020-12-15 21:12:15 +0000
commit30ba1a28dc305aa31411695832a47e24c5a864b3 (patch)
tree66e855b0df34d7ff01535e4de0d17d21675725a7 /zephyr/test/i2c/CMakeLists.txt
parent88530597d9aa9363ccb63a30e97e0bd8243b2d91 (diff)
downloadchrome-ec-30ba1a28dc305aa31411695832a47e24c5a864b3.tar.gz
zephyr: put project(...) after find_package(Zephyr)
When including the Zephyr source, this will change the values of CMAKE_C_COMPILER and CMAKE_CXX_COMPILER, causing cmake to execute again having forgotten about some of the command (since these are cached variables). BUG=b:175248887 BRANCH=none TEST=zmake testall, no "cached variables have changed" from cmake Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Change-Id: I7eb1004060b0ba51d8c336dfe507ad747abe80ee Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2591627 Reviewed-by: Simon Glass <sjg@chromium.org>
Diffstat (limited to 'zephyr/test/i2c/CMakeLists.txt')
-rw-r--r--zephyr/test/i2c/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/zephyr/test/i2c/CMakeLists.txt b/zephyr/test/i2c/CMakeLists.txt
index 29b3f1e65d..94c5deb8cc 100644
--- a/zephyr/test/i2c/CMakeLists.txt
+++ b/zephyr/test/i2c/CMakeLists.txt
@@ -2,8 +2,8 @@
cmake_minimum_required(VERSION 3.13.1)
set(BOARD native_posix)
-project(base32)
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+project(base32)
# Need to ensure that we are including only zephyr definitions in include files
# We cannot set these via kconfig, since this unit test does not bring in the