summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b2f3525fe..34e81f2be9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,9 @@ endif()
set(PLATFORM_EC "${ZEPHYR_CURRENT_MODULE_DIR}" CACHE PATH
"Path to the platform/ec repo.")
+set(PLATFORM_EC_PROGRAM_DIR "${PLATFORM_EC}/zephyr/program" CACHE PATH
+ "Path to the root directory containing all Zephyr EC programs and projects.")
+
if(NOT EXISTS "${PLATFORM_EC}/zephyr/module.yml")
message(FATAL_ERROR "Failed to resolve PLATFORM_EC at
${PLATFORM_EC}/zephyr/module.yml")