summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index c736fb6a18..af577cdc34 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -61,6 +61,9 @@ if(DEFINED CONFIG_PLATFORM_EC)
# with Zephyr builds only.
zephyr_compile_definitions("CONFIG_ZEPHYR")
+ # Force compiler warnings to generate errors
+ zephyr_compile_options(-Werror)
+
# When LTO is enabled, enable only for the "app" library, which compiles
# and links all Chromium OS sources.
# TODO: Enable LTO for all sources when Zephyr supports it.