summaryrefslogtreecommitdiff
path: root/zephyr/projects/guybrush/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/projects/guybrush/CMakeLists.txt')
-rw-r--r--zephyr/projects/guybrush/CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/zephyr/projects/guybrush/CMakeLists.txt b/zephyr/projects/guybrush/CMakeLists.txt
index b565aad308..30e8b8c611 100644
--- a/zephyr/projects/guybrush/CMakeLists.txt
+++ b/zephyr/projects/guybrush/CMakeLists.txt
@@ -9,9 +9,11 @@ project(guybrush)
zephyr_library_include_directories(include)
-set(PLATFORM_EC_BASEBOARD "${PLATFORM_EC}/baseboard/guybrush" CACHE PATH
- "Path to the platform/ec baseboard directory")
-set(PLATFORM_EC_BOARD "${PLATFORM_EC}/board/guybrush" CACHE PATH
- "Path to the platform/ec board directory")
-
zephyr_library_sources("power_signals.c")
+
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC
+ "usbc_config.c"
+ "usb_pd_policy.c")
+
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_COMMON
+ "led.c")