summaryrefslogtreecommitdiff
path: root/zephyr/projects/kohaku/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/projects/kohaku/CMakeLists.txt')
-rw-r--r--zephyr/projects/kohaku/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/zephyr/projects/kohaku/CMakeLists.txt b/zephyr/projects/kohaku/CMakeLists.txt
index a9dc7e910b..338e936f46 100644
--- a/zephyr/projects/kohaku/CMakeLists.txt
+++ b/zephyr/projects/kohaku/CMakeLists.txt
@@ -3,6 +3,16 @@
# found in the LICENSE file.
cmake_minimum_required(VERSION 3.13.1)
+
+# Append ${PLATFORM_EC}/zephyr/include/drivers to SYSCALL_INCLUDE_DIRS
+# variable for generating __syscall api functions by the
+# `gen_syscalls.py` script.
+# TODO: remove this when zmake support
+list(APPEND
+ SYSCALL_INCLUDE_DIRS
+ "${CMAKE_CURRENT_LIST_DIR}/../../include/drivers"
+)
+
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(kohaku)