summaryrefslogtreecommitdiff
path: root/zephyr/projects/skyrim/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/projects/skyrim/CMakeLists.txt')
-rw-r--r--zephyr/projects/skyrim/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/zephyr/projects/skyrim/CMakeLists.txt b/zephyr/projects/skyrim/CMakeLists.txt
new file mode 100644
index 0000000000..f75113bc21
--- /dev/null
+++ b/zephyr/projects/skyrim/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright 2021 The Chromium OS Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+
+find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
+project(guybrush)
+
+zephyr_library_include_directories_ifdef(CONFIG_BOARD_SKYRIM include)
+zephyr_library_include_directories_ifdef(CONFIG_BOARD_GUYBRUSH include_guybrush)
+
+zephyr_library_sources_ifdef(CONFIG_BOARD_SKYRIM "power_signals.c")
+zephyr_library_sources_ifdef(CONFIG_BOARD_GUYBRUSH "power_signals_guybrush.c")
+
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC
+ "usbc_config.c"
+ "usb_pd_policy.c")
+
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_COMMON
+ "led.c")