summaryrefslogtreecommitdiff
path: root/zephyr/projects/volteer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/projects/volteer/CMakeLists.txt')
-rw-r--r--zephyr/projects/volteer/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/zephyr/projects/volteer/CMakeLists.txt b/zephyr/projects/volteer/CMakeLists.txt
index 45b1e5300f..e73a98bb37 100644
--- a/zephyr/projects/volteer/CMakeLists.txt
+++ b/zephyr/projects/volteer/CMakeLists.txt
@@ -7,6 +7,15 @@ cmake_minimum_required(VERSION 3.13.1)
set(BOARD_ROOT ${CMAKE_CURRENT_LIST_DIR})
set(BOARD volteer)
+
+# Append {ZEPHYR_CHROME}/include/drivers to SYSCALL_INCLUDE_DIRS variable for
+# generating __syscall api functions by the `gen_syscalls.py` script.
+# TODO: remove this when zmake support
+list(APPEND
+ SYSCALL_INCLUDE_DIRS
+ ${CMAKE_CURRENT_LIST_DIR}/../../../include/drivers
+)
+
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(volteer)